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Model  Description     

MDT630A 3-Axis Flexure System with Stage and Controller 
MAX302 NanoMax Stage with Piezoelectric Actuators  
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WEEE 
As required by the WEEE (Waste Electrical and Electronic Equipment Directive) of the European Community and the 
corresponding national laws, Thorlabs offers all end users in the EC the possibility to return “end of life” units without incurring 
disposal charges. 

This offer is valid for Thorlabs electrical and electronic equipment 

 sold after August 13th 2005  

 marked correspondingly with the crossed out “wheelie bin” logo (see fig. 1) 

 sold to a company or institute within the EC  

 currently owned by a company or institute within the EC  

 still complete, not disassembled and not contaminated 

As the WEEE directive applies to self contained operational electrical and electronic products, this “end of life” take back 
service does not refer to other Thorlabs products, such as 

 pure OEM products, that means assemblies to be built into a unit by the user (e. g. OEM laser driver cards)  

 components  

 mechanics and optics  

 left over parts of units disassembled by the user (PCB’s, housings etc.).   

If you wish to return a Thorlabs unit for waste recovery, please contact Thorlabs or your nearest dealer for further 
information. 

Waste treatment on your own responsibility 

If you do not return an “end of life” unit to Thorlabs, you must hand it to a company specialized in waste recovery. Do not dispose 
of the unit in a litter bin or at a public waste disposal site. 

Ecological background 

It is well known that WEEE pollutes the environment by releasing toxic products during decomposition. The aim of the 
European RoHS directive is to reduce the content of toxic substances in electronic products in the future. 

The intent of the WEEE directive is to enforce the recycling of WEEE. A controlled recycling of end of live products will 
thereby avoid negative impacts on the environment. 

 

Crossed out “wheelie bin” symbol 
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Section 1: Safety Warnings 
 

 

WARNING: HIGH VOLTAGE OUTPUTS 

 

 

The MDT693A can produce hazardous voltages and currents. Use CAUTION when operating the MDT693A or MDT694A 
and handling the piezo actuators! The piezo elements are electrical capacitors capable of storing electrical energy over 
long periods of time. Besides storing charge from the MDT693A or MDT694A, the piezo can accumulate static charge 
over time due to varying storage temperature and/or mechanical loads. To safely discharge a piezo, connect it to the 
MDT693A or MDT694A and set the output voltage to 0 volts. 

 

 

WARNING:  HIGH VOLTAGE INSIDE. TO AVOID ELECTRICAL SHOCK THE POWER CORD 
PROTECTIVE GROUNDING CONDUCTOR MUST BE CONNECTED TO GROUND. DO NOT 
REMOVE COVER. REFER SERVICING TO QUALIFIED PERSONEL. 

 

Thorlabs provides the proper power input cable with each MDT693A and MDT694A.  If something should go wrong with 
the unit, do not attempt to fix. Call a Thorlabs representative and arrange for repair. The unit should never be opened 
unless changing the fuse or line voltage as described in Section 5. 

 

  

WARNING: THE UNIT MUST BE POWERED OFF, UNPLUGGED FROM THE AC INPUT POWER 
SOURCE, AND DISCONNECTED FROM ALL EXTERNAL DEVICES BEFORE REPLACING THE 
FUSE. FAILURE TO DO SO MAY CAUSE SERIOUS INJURY TO THE USER SINCE HIGH 
VOLTAGES EXIST WITHIN THE UNIT. 

 

 

 

WARNING: WHEN TURNING OFF THE UNIT, THE OUTPUT MAY EXPERIENCE A VOLTAGE 
FLUCTUATION ON THE OUTPUT TO THE PIEZO STACK. WHILE THIS DOES NOT DAMAGE THE 
PIEZO ACTUATOR, IT WILL CHANGE THE POSITION OF THE OPTO-MECHANICAL DEVICE. 
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Section 2: Specifications 

 2.1 Physical Features: 
  MDT693A MDT694A 
 Dimensions (W x H x D): 12.25” x 3.25” x 8” 5.8” x 2.8” x 12.5” 
  (311.2mm x 82.5 x 203.2mm) (147mm x 71mm x 317.5mm) 
 Input and Output Connectors: BNC1 ----- 
 Manual Controls (DC Offset) 2: 10-Turn Potentiometer ----- 

Scan Trim Controls (Scaling): 12-Turn Potentiometer N/A 
Number of Channels: 3 1 
Number of Displays: 3 1 
Display Type: LCD ----- 
Display Color: Green ----- 

 No of Digits: 3 ½ (000.0 to 150.0) ----- 
 Display Resolution: ±0.1 ----- 
 Weight: tbd tbd 
 Operating Temperature: 10 - 40C ----- 

 2.2 Power Supply: 
 Input Power Connection3: IEC Connector ----- 
 Supply Type: Linear ----- 
 Voltage Selection: Switch Selectable (115 / 230) ----- 
 Input Voltage: 100/115VAC ±10%†  
   230VAC ± 10% ----- 
 Line Frequency: 50 – 60Hz ----- 
 Input Power: 85VA max 30VA max 
 Fuse Ratings: 630mA @ 115VAC† 500mA @ 115VAC† 
   400mA @ 230VAC 250mA @ 230VAC 
 Fuse Type:  IEC60127-2/III ----- 
   (250V, Slow Blow Type ‘T’) 
 Fuse Size:  5 x 20mm -----  

 2.3 Input / Output Specifications: 
 Ext. Input Voltage Range4: 0 – 10V ----- 
 Ext. Input Impedance4: 10K ----- 
 Output Voltage Range5 
  Volt Limit Pos 1 (75V)†: 0 - 75V ----- 
  Volt Limit Pos 2 (100V): 0 - 100V ----- 
  Volt Limit Pos 3 (150V): 0 – 150V ----- 
 Max Output Current5: 60mA (current limited) ----- 
 Output Impedance5: 150, 0.047µF ----- 
 Min Load Impedance7: 2.5k ----- 
 EXT Input Gain4 
  Volt Limit Pos 1 (75V)†: 7.5 V/V ±5% ----- 
  Volt Limit Pos 2 (100V): 10 V/V ±5% ----- 
  Volt Limit Pos 3 (150V): 15 V/V ±5% ----- 
 Output Noise6: 1.5mVRMS (~9.9Vpp) ----- 
 -3dB Bandwidth8 
  No Load, Small Signal: 10 kHz ----- 
  No Load, 150Vpp: 8.5 kHz ----- 
  1.6µF Piezo (AE0505D16), 150V: 250 Hz ----- 
 Stability: < 0.01% over 5hrs ----- 
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 2.4 A/D and D/A Performance 
 D/A Resolution: 16-bit ----- 
  Output Voltage Range: 0 to 150V ----- 
  Voltage Resolution: 2.75mV ----- 
 A/D Resolution: 16-bit ----- 
  Voltage Resolution: 3mV ----- 

 2.5 Communications: 
 Communications Port: RS232 ----- 
 Com Connection: DB9 Female (Rear Panel) ----- 
 Required Cable9: DB9 Male to Female (Provided) ----- 
 Protocol: 
  Baud Rate: 9600, 14400, 19200, 28800, 34800 ----- 
   57600, 76800, 115200† bps 
  Data Bits: 8 
  Stop Bits: 1 
  Parity: None 
  Handshaking: None 
 Baud Rate Set: 4-Pos Dip Switch (Internal) ---- 
  

Notes: 

 † Factory Default Setting. 

1. To operate the MDT693A or MDT694A with Thorlabs Nanomax stages BNC to SMC cables must be used. 

2. Includes X AXIS INT, Y AXIS INT, Z AXIS INT and MASTER SCAN INT for the MDT693A and INT for the MDT694A. 

3. The MDT693A and MDT694A are supplied with a US style power cord. Units purchased in other countries must supply their own certified 
rated power cord. 

4. Includes X AXIS EXT, Y AXIS EXT, Z AXIS EXT and MASTER SCAN EXT for the MDT693A and EXT for the MDT694A. 

5. Includes X AXIS, Y AXIS, and Z AXIS OUTPUTS located on the rear panel of the MDT693A and OUTPUT on the front panel of the MDT694A. 

6. The MDT693A and MDT694A were tested without an external load connected (0.047µF output impedance only). Adding a capacitive load, 
such as a piezo will decrease the noise spec since the capacitance will create a low pass filter with the output resistance. 

7. The Min Load Impedance represents the smallest allowable terminating resistance. Applying lower impedances will cause the short circuit 
protection to limit the output voltage. Continued use in this mode will cause circuit degradation and eventual circuit failure. 

8. Assume a ramp function is used. The bandwidth is load dependent and requires calculation for a more representative number. See the 
Bandwidth section for details. 

9. Do not use a null modem cable. 
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Section 3: Description 
The MDT693A and MDT694A are precision, low-noise, low-drift, high voltage controllers for piezo actuators. The 
MDT693A provides three channels while the MDT694A is a single channel unit. The controllers provide both manual and 
external control of the piezo drive voltages. The MDT694A is ideal for single piezo control such as the Thorlabs PE4 or 
AE-series piezos, while the MDT693A can control multiple axis piezo stages such as Thorlabs KC1PZ or MAX312. 
Typical applications include remote alignment of single-mode fiber couplers, high-resolution translation, microscopy, 
remote positioning, etc. 

Precision 10-turn potentiometers on the front panel allow for precise manual setting of the outputs over the full operating 
range. This allows hands-off control of the piezo translators to take full advantage of the inherently high resolution of the 
piezo element. The MDT693A provides independent controls for each channel. 

The drive voltage can also be controlled externally by applying an analog voltage (from 0 to 10V) to the front panel BNC 
inputs or remotely controlled by a computer terminal through an RS-232 interface. This voltage is multiplied by the 
selected gain setting and summed with the manual control voltage. 

I.e. VOUT = VMANUAL + (GAIN * VEXT) + VRS232 

The external control voltage can be supplied by any stable voltage source including function generators, DAC outputs, or 
DC supplies. Also, the external voltage can be used as part of a feedback loop for automated alignment systems. Since 
both the manual control and the external input voltage are summed, the manual control can be used for offset 
adjustments without having to readjust the external voltage source. 

Both the MDT693A and the MDT694A include a voltage limit switch on the rear panels to select the operating voltage 
ranges and gains for the units. Each unit is shipped set for 0 – 75V (Gain = 7.5 V/V) operation and may be adjusted by the 
user to provide 0 – 100V (Gain = 10 V/V) and 0 – 150V (Gain = 15 V/V) ranges. 

The MDT693A Master Scan feature allows all three channels to be controlled by one manual adjustment or by one 
external control signal. In this mode, each channel can be precisely adjusted by an offset voltage (i.e. the INT control knob 
for each axis) and by a gain adjustment (i.e. SCAN TRIM adjustment pot for each channel). The gain adjustment allows 
the output for each channel to be amplified from 80 to 120 % of the master control signal. 

The MDT693A and MDT694A include 3 ½ digit LED readouts for displaying the instantaneous output voltages of all three 
channels. The input power is switch selectable for 115VAC or 230VAC operation. 

 

Section 4: Parts List 
Below is a list of all components shipped with the MDT693A/MDT694A Piezo Controller. 

 MDT693A or MDT694A Control Box 
 Operating Manual 
 Fuse Replacement Datasheet 
 Software CD 
 Power Supply Line Cord 
 DB9 Serial Port Cable 
 Replacement Fuse for 230VAC operation (400mA fuse for MDT693A’s; 250mA fuse for MDT694A’s) 

The following items are sold separately: 

 2249-C-xx Series: BNC Coaxial Cables 
 CA26xx Series: BNC male to SMC male Coaxial Cables 
 AE Series: Standalone Piezo Stacks 
 PE4: Piezo/Screw Actuator 
 MAX300 Series: 3-Axis NanoMax Flexure stages 
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Section 5: Fuse Replacement / Line Voltage Selection 
Thorlabs ships it MDT693A and MDT694A units configure to operate at 115VAC. The line voltage and installed fuse must 
be changed to operate this unit at 230VAC. To operate at 100VAC, use the 115VAC setting. Follow the instructions below 
to change the line voltage if necessary.  

 WARNING: THE UNIT MUST BE POWERED OFF, UNPLUGGED FROM THE AC INPUT POWER 
SOURCE, AND DISCONNECTED FROM ALL EXTERNAL DEVICES BEFORE REPLACING THE FUSE. 
FAILURE TO DO SO MAY CAUSE SERIOUS INJURY TO THE USER SINCE HIGH VOLTAGES EXIST 
WITHIN THE UNIT. 

 

5.1 Materials Needed 
 MDT693A/MDT694A Operating Manual – The most recent version of this operating manual will be available on 

Thorlabs web site. 

 400mA Type IEC60127-2/III – (5x20mm, 250V, Slow Blow Type ‘T’) The 400mA fuse is required for 230V 
operation of the MDT693A. Thorlabs supplies a 400mA fuse with all of its MDT693A units and must be installed 
when operating at 230VAC. 

 630mA Type IEC60127-2/III – (5x20mm, 250V, Slow Blow Type ‘T’) The 630mA fuse is installed in MDT693A’s 
from the factory. This must be installed when operating the unit at 100 / 115VAC.  

 250mA Type IEC60127-2/III – (5x20mm, 250V, Slow Blow Type ‘T’) The 250mA fuse is required for 230V 
operation of the MDT694A. Thorlabs supplies a 250mA fuse with all of its MDT694A units and must be installed 
when operating at 230VAC. 

 500mA Type IEC60127-2/III – (5x20mm, 250V, Slow Blow Type ‘T’) The 500mA fuse is installed in MDT694A’s 
from the factory. This must be installed when operating the unit at 100 / 115VAC. 

 Flat Head Screwdriver – This is required to open the fuse holder. 

5.2 Fuse Replacement and Line Voltage Selection 
1. Important – Disconnect all piezos from outputs and disconnect any input signals present. 

2. Important – Disconnect the power cord. Do not open the unit if the power cord is connected. See warning 
above. 

3. Locate the fuse holder below the power input connector. Slide the fuse tray out using a flat head screwdriver. 
Remove the fuse and replace with the appropriate value as described below: 

MDT693A 
 400mA Type IEC60127-2/III (5x20mm, 250V, Slow Blow Type ‘T’) for 230VAC operation 
 630mA Type IEC60127-2/III (5x20mm, 250V, Slow Blow Type ‘T’)for 100/115VAC operation 

MDT694A 
 250mA Type IEC60127-2/III (5x20mm, 250V, Slow Blow Type ‘T’)for 230VAC operation 
 500mA Type IEC60127-2/III (5x20mm, 250V, Slow Blow Type ‘T’)for 100/115VAC operation 

4. To change the line voltage, locate the line select on the rear panel. Select the appropriate line voltage by 
adjusting the switch to either 110 or 220. Select 110 if operating at 100VAC to 120VAC. Select 220 for operation 
from 220VAC to 240VAC. 
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Section 6: Getting Started Quickly 
This section is provided for those interested in getting the MDT693A or MDT694A up and running quickly as a basic piezo 
controller. The more advanced features are described in detail in the following sections. 

6.1 Setup  
1. Carefully unpack the controller and accessories. See section 4 for a complete list of parts. If any of the items 

appear damaged or missing, do not use the controller. Call Thorlabs, or email RMA@thorlabs.com and arrange 
for a replacement. 

2. If necessary change the input line voltage and replace the fuse. The MDT693A/MDT694A can be operated from 
100/115VAC or 230VAC. A voltage selector switch is located on the rear panel of the controller. If you are not 
sure what operating voltage your unit is set to, proceed immediately to Section 5.0 for instructions on setting the 
operating voltage. 

3. Attach the AC line cord to the MDT693A/MDT694A power input connector located on the back of the unit. Plug 
the unit into an AC outlet.  

4. Verify that the unit is turned off. 

5. Select the appropriate output voltage limit on the rear panel. The user can chose between a 75V (7.5V/V), a 100V 
(10 V/V), or 150V (15 V/V) limits. This switch should only be adjusted while the unit is off. The internal 
microprocessor will only check the status of this switch on startup and will set offsets and voltage 
scaling accordingly. Changing this setting while the unit is on will cause voltage-scaling problems when 
using the serial communication and may damage any piezo connected to the outputs. 

6. Connect the piezo device to the controller output(s). Do not connect piezo devices to the unit while the unit is on. 
This can cause damage to the piezo device. 

7. Turn the controller on. 

8. Use the ‘INT’ control knobs to adjust the piezo output voltage. For more advanced controls such as the external 
input, master scan controls, or serial operation see the operating instructions. 
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Section 7: Description 

7.1 MDT693A Front Panel Features 

POWER

EXT
SCAN
TRIM

INT

VOLTAGE 75V 100V 150V

VOLTS

X-AXIS

INT
SCAN
TRIM

EXT

VOLTS

Y-AXIS

INT
SCAN
TRIM

EXT

VOLTS

Z-AXIS MASTER SCAN

EXT INT

ENABLE

3-AXIS PIEZO CONTROLLER     MDT693A

LIMIT:

0-10V 0-10V 0-10V

0-10V

2 3 4 7 8 9

6510 1

 

Figure 1 – MDT693A Front Panel 

 Feature: Description 

 1 3 ½ Digit LED Display – A 3 ½ digit display is used to view the output voltage for each channel.  

 2 EXT INPUT BNC - This input is used to externally control the output. The input voltage range is 0 to 
10V with a gain of 7.5, 10, or 15 V/V depending on the ‘Output Voltage Limit’ setting. There is one 
input for each channel. 

 3 INT Knob – This knob will adjust the output voltage from 0 to 75, 100, or 150VDC. It can also be used 
as an offset for any external input, since it is summed with the EXT INPUT BNC. There is a separate 
control knob for each channel. 

 4 EXT SCAN TRIM – This will adjust the output gain for each channel from 80% to 120% while in the 
Master Scan mode.  

 5 MASTER SCAN EXT – Add a 0 to 10V analog signal to this input to control all three outputs. This 
input is summed with MASTER SCAN INT, SCAN TRIM and INT. The Master Scan mode must be 
enabled to use this feature. 

 6 MASTER SCAN INT – The Master Scan INT knob will allow the user to adjust the DC offset of all 
three channels over the full operating range. The Master Scan mode must be enabled to use this 
feature. 

 7 MASTER SCAN Enable LED – will indicate when the MDT693A is operating in the Master Scan 
mode. 

 8 ENABLE Button – This button is used to enable the master scan mode. 

 9 POWER Button – Press in to turn the MDT693A on. 

 10 Voltage Limit Indicator – These LED will indicate voltage limit setting. The Limit setting can be 
adjusted through the rear panel switch marked “OUTPUT LIMIT”. 
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7.2 MDT693A Rear Panel Features 

2
30
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Figure 2 – MDT693A Rear Panel 
 Feature: Description: 

 1 AC input receptacle – This input requires an IEC compatible plug with a properly connected ground 
terminal. Thorlabs supplied a cord for operation in the United States. 

 2 Fuse Holder – The system fuse is installed here. See section 5 for more details. 

 3 Line Voltage Selector Switch – This switch adjusts the line voltage operation. The factory default is 
115 and must be adjusted to operate where the line voltage is 220 – 240VAC. 

 4 Cooling fan – Do not block when the unit is operating. 

 5 Output Limit Switch – Use this to select the output voltage limit and adjust the EXT input gain value. 
The output voltage limit can be set to 75, 100, or 150V (7.5, 10, 15 V/V gain). Do not adjust when 
the unit is powered on. 

 6 RS232 Connector – Use this to communicate to a PC through serial control. Use a standard DB9 
male to DB9 female (Included) cable for connection. 

 7 High Voltage Outputs – These BNC’s are used for the piezo connections. Caution: These are high 
voltage outputs which could cause a shock if accessing without a piezo installed.  The outputs on 
these connectors are the sum of the adjustment knob, the external voltage control and the serial 
control. 
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7.3 MDT694A Front Panel Features  
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Figure 3 – MDT694A Front Panel 

  

Feature:Description: 

 1 INT Knob – This knob will adjust the output voltage from 0 to 75, 100, or 150VDC. It can also be used 
as an offset for any external input, since it is summed with the EXT INPUT BNC. There is a separate 
control knob for each channel. 

 2 POWER Button – Press in to turn the MDT694A on. 

 3 Voltage Limit Indicator – These LED’s will indicate the voltage limit setting. The Limit setting can be 
adjusted through the rear panel switch marked “OUTPUT LIMIT”. 

 4 3 ½ Digit LED Display – A 3 ½ digit display is used to view the output voltage. 

 5 High Voltage Output – This BNC is used for the piezo connection. Caution: This is a high voltage 
output which could cause a shock if accessing without a piezo installed.  The output on this connector 
is the sum of the adjustment knob, the external voltage control and the serial control. 

 6 EXT INPUT BNC - This input is used to externally control the output. The input voltage range is 0 to 
10V with a gain of 7.5, 10, or 15 V/V depending on the ‘Output Voltage Limit’ setting. 
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7.4 MDT694A Rear Panel Features  
 

250mA FUSE

500mA FUSE50-60Hz

50-60Hz230VAC

100/115VAC 
S.N.

www.thorlabs.com
NEWTON NJ 07821

MODEL #: MDT694A

23
0V

LIMIT

75V
100V

OUTPUT

150V

RS232

WARNING: HIGH VOLTAGE INSIDE. TO AVOID ELECTRICAL SHOCK THE 
POWER CORD PROTECTIVE GROUNDING CONDUCTOR MUST BE 
CONNECTED TO GROUND. DO NOT REMOVE COVER. REFER SERVICING 
TO QUALIFIED PERSONNEL.

USE 250V, TYPE T, 5X20MM, 
SLO BLOW FUSES ONLY

MAX POWER 30VA

1 32 4 5
 

Figure 4 – MDT694A Rear Panel 

 

 Feature: Description: 

 1 RS232 Connector – Use this to communicate to a PC through serial control. Use a standard DB9 
male to DB9 female (Included) cable for connection. 

 2 Output Limit Switch – Use this to select the output voltage limit and adjust the EXT input gain value. 
The output voltage limit can be set to 75, 100, or 150V (7.5, 10, 15 V/V gain). Do not adjust when the 
unit is powered on. 

 3 Line Voltage Selector Switch – This switch adjusts the line voltage operation. The factory default is 
115 and must be adjusted to operate where the line voltage is 220 – 240VAC. 

 4 Fuse Holder – The system fuse is installed here. See section 5 for more details. 

 5 AC input receptacle – This input requires an IEC compatible plug with a properly connected ground 
terminal. Thorlabs supplied a cord for operation in the United States. 
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Section 8: Operating Instructions 
 

WARNING: THE MDT693A AND MDT694A CAN PRODUCE HAZARDOUS VOLTAGES AND 
CURRENT. USE CAUTION WHEN OPERATING THIS UNIT. 

 

 

8.1 Setting the Output Voltage Limit 
Both the MDT693A and the MDT694A include a voltage-limiting switch on the rear panel that can be used to limit the 
output voltage range for lower drive voltage piezos. Thorlabs ships the controllers to operate with the 75V limit as a 
default. The user can easily adjust this value as described below: 

1. Determine the maximum allowable voltage for your piezo element. We recommend the following settings: 

 Use the 150V Limit Setting when VPIEZO > 150V. 
 Use the 100V Limit Setting when 150V > VPIEZO > 100V. 
 Use the 75V Limit Setting when 100V > VPIEZO > 75V. 
Where VPIEZO is the piezo element maximum voltage 

2. Power off the MDT693A, or MDT694A. Do not adjust the voltage limit switch when the unit is powered on. 

3. Locate the Voltage Limit switch on the rear panel of the MDT693A/MDT694A. 

4. Adjust the switch to the desired limit setting as determined above. 

5. Turn the Controller On. The onboard micro controller will automatically configure the controller to the appropriate 
settings. The gain of the EXT input BNC’s will vary depending on the gain setting. For the 150V setting the gain is 
15V/V, for the 100V setting the gain is 10V/V, and for the 75V setting the gain will be 7.5V/V. 

8.2 Using the INT Adjustment Knob 
The INT knobs manually control the output voltages for each channel between 0 and 150 VDC. It can also be described 
as a DC offset voltage since it will be summed with the external input control and RS-232 control. Follow the procedure 
described below for operation in this mode. 

1. Attach a piezo to each of the high voltage output connectors on the MDT693A rear panel or to the front panel 
output connector of the MDT694A. 

Note: the BNC center conductor is positive and the shield is at ground potential. Be certain to match 
piezo polarity to the connector since most piezo elements will be permanently damaged if connected 
backwards. 

2. Set all the output voltages to 0V by turning the manual control knobs counter-clockwise until the mechanical stop 
is reached. 

3. Turn the power switch (located on the front panel) to the ON position. The digital displays should begin displaying 
the output voltages. 

4. Adjust the INT knob for each channel until the desired voltages are displayed or until the desired displacements 
are met. 

Note: the maximum output voltage for the MDT693 is 150V per channel. This may be too high for some 
piezo elements. 

8.3 Using the EXT INPUT BNC 
The EXT inputs on both the MDT693A and MDT694A are designed to allow the user to modulate the channel output or to 
be used as a feedback for positioning systems. Examples of connections for this input include D/A systems, strain gages 
with support electronics, and function generators. This control is summed with the INT control knob and the serial port 
control. To use this feature, follow the steps below.  
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1. Attach a piezo to each of the high voltage output BNC connectors, located on the rear panel of the MDT693A or 
to the front panel output connector of the MDT694A. 

Note: the BNC center conductor is positive and the shield is at ground potential. Be certain to match 
piezo polarity to the connector since most piezo elements will be permanently damaged if connected 
backwards. 

2. Set the output voltages to 0V by turning the manual control knobs counter-clockwise until the mechanical stop is 
reached. 

3. Turn the power switch on. 

4. Connect an analog input signal (AC or DC), with a voltage between 0 and 10V, to the EXT INPUT BNC’s. The 
output for each channel will follow the EXT Input voltage with a gain of 7.5, 10, or 15V/V.  

Note: do not place a negative voltage on the EXT input BNC. The MDT693A/MDT694A includes reverse 
protection diodes on the EXT inputs. These are designed to prevent the piezo output from going negative. 
Inputting negative voltages for long periods of time will damage these diodes and effect the operation of 
the unit. 

5. For sinusoidal and ramp signals, calculate the output current and verify that it will not exceed the maximum 
current rating of 60mA. A piezo acts like a capacitor; therefore the output current is a function of the change in 
voltage divided by the change in time (see Appendix A for details). The MDT693A and MDT694A have an output 
current limiting circuit to prevent damage to the unit, however the output sinusoid will be distorted. 

8.4 Using the MASTER SCAN controls (MDT693A Only) 
The master scan controls are provided so that the user can control all three channels from a single source. This source 
can be an external voltage or a manual control knob. Each channel also has a gain adjustment, which allows the user to 
compensate for differences in the piezos. The output of each channel is summed with the INT adjustment knobs to allow 
for a dc offset. 

The Master Scan mode is especially useful for adjusting three axis mounts such as the MAX312 and KC1PZ. The SCAN 
TRIM gain controls and the INT control knobs allow the user to precisely tune each output separately, while the MASTER 
SCAN INT and EXT controls allow the user to adjust all three channels in sync. 

8.4.1 Enable Button  

The ENABLE button located on the front panel (see Section 7.1 – MDT693A Front Panel Features) is used to enable and 
disable the master scan mode. 

8.4.2 Enable LED 

The enable LED, located directly above the ENABLE button, will light when the master scan mode is activated. 

8.4.3 MASTER SCAN EXT 

An analog voltage between 0 and 10V can be applied to this input to control all three channels over a voltage range of 0 
to 75, 100 or 150V. This input will be summed with the MASTER SCAN INT and the individual INT knobs for each 
channel. The MASTER SCAN EXT input will only be active in the MASTER SCAN mode (i.e. the enable LED must be lit). 

8.4.4 MASTER SCAN EXT 

The MASTER SCAN INT knob will allow the user to adjust all three channels over the full operating range of 0 to 75, 100, 
or 150V. The MASTER SCAN INT knob will only be active in the MASTER SCAN mode (i.e. the enable LED must be lit). 

8.4.5 MASTER SCAN EXT 

The SCAN TRIM adjustments scale each channel separately with a gain of 80% to 120% of the Master Scan INT and 
EXT signals. This is useful to compensate for differences in reactance from one piezo to another. The SCAN TRIM 
adjustments are only active in the MASTER SCAN mode (i.e. the enable LED must be lit).  



_________________________________________________________________________________________________ 

  
Doc 12534-D02 Rev F 2/8/2012 

Page 18 of 29 

Note: the 100% mark is half way through the adjustment range of the SCAN TRIM potentiometer. To approximately 
set the SCAN TRIM to 100% turn the pot a minimum of four turns CCW (zero the pot). Adjust the pot CW two turns. To 
precisely set the SCAN TRIM to 100% follow the procedure below: 

 Adjust all of the INT control knobs CCW as far as they will go. 

 Disconnect any EXT input connections. 

 Adjust the SCAN TRIM pots a minimum of 4 turns CCW. 

 Apply a 5V dc voltage source to the MASTER SCAN EXT BNC. 

 Adjust the SCAN TRIM pots CW until their display reads 75 volts (assuming the voltage limit is 150V). 

 

Section 9: Serial Port 

9.1 Overview 
The MDT693A and MDT694A serial control is designed specifically to interface the controller directly to computer 
terminals. The user can operate the piezo driver remotely, or easily incorporate Thorlabs drivers into automated control 
systems. The output voltage of the piezo driver is directly controlled through software, eliminating the need for external 
control voltages such as lab power supplies, frequency generators, or analog output cards. Simple functions such as sine 
waves, voltage ramps, and pulses are possible through PC control.  

The MDT693A/MDT694A communicates via a standard RS-232 serial port using most of the common baud rate settings 
up to 115200Kbs. The baud rate is selectable using an accessible dipswitch, with a factory default baud rate setting of 
115200Kbs. The user may communicate directly with the controller using the provided commands and a serial emulator 
program such as HyperTerminal, through National Instruments LabView, or using the self-executable program provided. 

Each piezo output channel is controlled through a 16-bit D/A converter, while an onboard microprocessor interfaces to a 
16-bit A/D converter to monitor the output voltage. Each unit is factory calibrated to eliminate all system offsets and 
provide a linear voltage range of 0 to 75, 100, or 150V.  

All user functions for the MDT693A and MDT694A are available within the provided software. The PC software is directly 
compatible to the National Instruments LabView environment, as well as standard RS-232 port emulation programs. All 
software upgrades can be downloaded from the Thorlabs website or requested through the Thorlabs technical support 
department. 

9.1.1 Self Executable Software Overview 

The self-executable software is a standalone program designed to provide access to all piezo driver hardware controls. In 
addition, a software signal generator is included to provide basic modulation control. Simple functions such as sine waves, 
ramps and pulses can be configured to control the piezo output. 

9.1.2 Software Manual 

The software manual is available in a *.pdf format. Also see section 10. 
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9.3 Baud Rate and Device Settings 

9.3.1 COM Port Protocol 

 Baud Rate: Table 1 (115200 default) 
 Data Bits: 8 
 Parity: none 
 Stop Bits: 1 
 Flow Control: none 

9.3.2 Setting the Baud Rate 

The MDT693A and MDT694A allow the user to choose a baud rate to better accommodate their system. The default baud 
rate is set to 115200Kbs and can be adjusted using the 4-position dipswitch, located inside the controller. Positions 1 to 3 
are dedicated to setting the baud rate. Position 4 is no longer used for the MDT693A or MDT694A and may be ignored. 
See the figure and table below to adjust the proper settings. Follow the directions below for accessing the dip switch. 

 

Figure 5 – Dip switch 

 

Table 1 – Dip Switch Settings 
1. Turn the unit off and unplug. Caution: High voltages are present inside when the unit is plugged in. DO NOT open 

the cover when the unit is plugged in.  

2. Allow the unit to sit for about 5 minutes to ensure all voltage supplies and high voltage circuitry has a chance to 
discharge. 

3. Remove the two screws holding the cover on. They can be found in the bottom rear of the unit. Slide the cover off. 

4. Locate the dipswitch on the main board. 

 MDT693A – Located at the front center of the unit below the two 2x5 headers.  

 MDT694A – Located at the front center between the power switch and the display connection. 

5. Set the appropriate settings using Table 1 for reference. 

6. Replace the cover and reinstall the two screws. 

7. Turn the unit on. 
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9.4 Serial Command Summary 
 Command: AV 
 Input Parameters: <voltage> 
 Description: Sets all outputs to the set voltage. This command can be compared to the Master Scan 

function on the front panel. 

 Command: XV 
 Input Parameters: <voltage> 
 Description: Sets the output voltage for the x axis of the MDT693A or to set the single output of the 

MDT694A to the desired voltage.  

 Command: YV 
 Input Parameters: <voltage> 
 Description: Sets the output voltage for the y axis of the MDT693A to the desired voltage.  This 

function has no affect when using with the MDT694A. 

 Command: ZV 
 Input Parameters: <voltage> 
 Description: Sets the output voltage for the z axis of the MDT693A to the desired voltage.  This 

function has no affect when using with the MDT694A. 

 Command: XR? 
 Input Parameters: ? 
 Description: Reads and returns the x axis output voltage for the MDT693A or the single output of the 

MDT694A.  

 Command: YR? 
 Input Parameters: ? 
 Description: Reads and returns the y axis output voltage for the MDT693A.  This function has no 

affect when using with the MDT694A. 

 Command: ZR? 
 Input Parameters: ? 
 Description: Reads and returns the z axis output voltage for the MDT693A.   This function has no 

affect when using with the MDT694A. 

 Command: XL 
 Input Parameters: <voltage> or ? 
 Description: This function sets the minimum output voltage limit for the x axis of the MDT693A or the 

single output of the MDT694A. Sending the ‘?’ parameter will return the current setting. 

 Command: YL 
 Input Parameters: <voltage> or ? 
 Description: This function sets the minimum output voltage limit for the y axis of the MDT693A. 

Sending the ‘?’ parameter will return the current setting.  This function has no affect when 
using with the MDT694A. 

 Command: ZL 
 Input Parameters: <voltage> or ? 
 Description: This function sets the minimum output voltage limit for the z axis of the MDT693A.  

Sending the ‘?’ parameter will return the current setting. This function has no affect when 
using with the MDT694A. 

 Command: XH 
 Input Parameters: <voltage> or ? 
 Description: This function sets the maximum output voltage limit for the x axis of the MDT693A or the 

single output of the MDT694A. Sending the ‘?’ parameter will return the current setting. 
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Command: YH 
 Input Parameters: <voltage> or ? 
 Description: This function sets the maximum output voltage limit for the y axis of the MDT693A. 

Sending the ‘?’ parameter will return the current setting.  This function has no affect when 
using with the MDT694A. 

 Command: ZH 
 Input Parameters: <voltage> or ? 
 Description: This function sets the maximum output voltage limit for the z axis of the MDT693A. 

Sending the ‘?’ parameter will return the current setting.  This function has no affect when 
using with the MDT694A. 

 Command: I 
 Input Parameters: none 
 Description: This command will return the product header, firmware version, etc. 

 Command: E 
 Input Parameters: none 
 Description: When the echo mode is on the command parameters will be returned, or echoed back, to 

the communication program. 

 Command: % 
 Input Parameters: none 
 Description: Returns the output voltage limit setting. 
  (75V returns 0, 100V returns 1, and 150V returns 2) 
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Section 10: Software Operation 

10.1 Software Installation 
All software required to operate the MDT693A and MDT694A can be found on the provided CD-ROM disk. Software 
updates may be available in the future and may be downloaded from the Thorlabs website at http://www.thorlabs.com. To 
install the software follow the procedure listed below. 

10.1.1 Software Requirements 

 Microsoft Windows 95/98/NT/2000/XP (Windows NT and 2000 will need administrator rights to install software) 
 PC with a Pentium/AMD class processor (Pentium II recommended) 
 32MB or more RAM recommended 
 6 MB hard disk space 
 CD-ROM drive 
 Mouse or compatible pointing device 
 800 x 600 minimum display resolutions 
 256-color minimum 

10.1.2 Software Installation Instructions 

1. Place the provided software disk into the CD-ROM drive. The install program should auto start. 

2. Start the Setup.exe file located on the CD-ROM disk if the auto start did not initiate. 

3. Follow the on-screen prompts. The default location will be C:\Program Files\Thorlabs\. Note that the software will 
look for installed files in the directory provided. If any are found the program will uninstall the existing software 
(see section 10.1.3 for details). Run setup.exe again to reinstall.  

Note: The Software will ask if you want to reboot. Select Yes. 

4. Make sure that the MDT693A, or MDT694A, is connected to the correct computer COM port. Turn on the 
MDT693A or MDT694A. 

5. Start the software by pressing "Start > Program Files > Thorlabs > MDT695".  

6. Refer to Section 10 for software operation. 

10.1.3 Software Uninstall Instructions 

1. Place the provided software disk into the CD-ROM drive. The install program should auto start. 

2. Start the Setup.exe file located on the CD-ROM disk if the auto start did not initiate. 

3. The setup program will prompt the user for the install directory. Enter the directory of the existing software if 
different from the default. 

4. The program will automatically uninstall any existing MDT695 software. 

5. To reinstall the software see section 10.1.2. 

10.2 Running the Software for the First Time 
To start the Thorlabs Piezo Controller Software, click on Start > Program Files > Thorlabs > MDT695. The software will 
automatically determine the device type, MDT693A or MDT694A, and will try to connect to the piezo driver. The unit must 
be turned on prior to starting the program.  

During the first time startup, the software will auto-detect the COM port and baud rate, starting with the system default 
values (i.e. baud = 115200KBs, port = COM1). If the device was not detected a communication error message will appear. 

See the troubleshooting section for details on how to correct this problem. The port and baud rate settings will be 
remembered by the program and will be used during startup. 
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10.3 Overhead Menu Options 

10.3.1 Exiting the Software 

To exit the software, click File > Exit in the top menu structure. 

10.3.2 Closing a Window 

To close a window, click File > Close in the top menu. This will always display the compact view. 

10.3.3 Setting the Default Startup Window 

The user can change the default startup window by clicking View > Start Window > {option}. The  will indicate the 
default startup device selected. The next time the user runs the piezo control software the default startup window will 
open. 

10.3.4 Manually Adjusting the Communication Settings 

It is possible to manually select the COM port and baud rate settings. To open the communications window click Tools > 
COM Setup. The window, seen below will appear. Select the "Manual Select" button and change the baud rate and COM 
port to the appropriate settings. Click the "Set Values" Button to remember settings. "OK will close the window. For further 
details on the communication protocol or hardware setup see "Appendix B – Baud Rate and Device Settings". 

 

Figure 6 – COM Port Settings 

10.3.5 Voltage Limit Settings 

Voltage limits may be set to limit the output voltage driving the piezo device. These voltage limits may be used for two 
purposes. They can provide a voltage limit that will prevent accidentally overdriving lower voltage piezos (Piezos with 
maximum voltages less than 150V). They may also be used to set the mechanical travel limits. 

It should be noted that these limits do not limit the MDT693A/MDT694A directly. The limits prevent devices from being 
overdriven by the software. They will not limit the adjustment knobs located on the front panel of the MDT693A or 
MDT694A. The MDT693A and MDT694A will add the manual control knobs, the external input, and the soft ware-
generated signals. For example, a 75V limit is set through software. The software and control card will not output a 
voltage greater than 75V. However, the user may still adjust the manual adjustment knob, or add a signal to the Ext Input 
BNC that will cause the output voltage to exceed 75V. 

To access the voltage limit window click Tools > System Setup in the top menu. See Figure 7 for details. Limits for each 
channel can be changed by clicking on the appropriate box and entering the voltage, or by using the up/down arrows. A 
global limit box is available to provide one limit for all channels. To use this option, check the enable box and fill in the limit 
values. Note that the X, Y, and Z limit adjustments will be made unavailable. Press "OK" to accept new values, “Cancel” to 
close panel, or "Restore Defaults" to reset all values to the max limit settings (min = 0V, max = 150V). 
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Figure 7 – Voltage Limit Window 

10.3.6 Help > About Windows 

The Help > About MDT695 screen will provide the customer with all of the pertinent information about the system such as 
the controller (MDT693A / MDT694A), software version, and firmware version. The Help > About Thorlabs window will 
provide the customer with all of the pertinent Thorlabs contact information. 

10.4 The Compact Window 
As soon as the Piezo Controller Software connects to the MDT693A/MDT694A the Compact window will appear (see 
figure 8). The software will automatically determine the host device, MDT693A or MDT694A, through the serial 
connection. 

 

Figure 8 – Compact Window 
The compact windows shown provide the simplest operation of the piezo controller. Thorlabs recognizes the need for a 
small interface window. In most cases the piezo controller software will be used while operating other software. To 
minimize interference the compact window should be used. 

10.4.1 Changing the Voltage 

The output voltage for each channel can easily be adjusted in three ways: 

1. The mouse cursor may be used to adjust the knob available for each channel. 

2. The  and  arrows may be used to increase or decrease the output voltage with a 0.1V resolution. 

3. The voltage may be directly changed by clicking on the text box and typing in the desired voltage. The text box 
will accept values to three decimal places. The output will be set to the nearest 16-bit value. 

Note that the display box will round this number, however this will not affect the voltage setting. 

10.4.2 Reset Buttons 

The reset buttons, marked "R", allows the user to quickly set the output voltages to the minimum voltage limit, typically 0 
volts (see the "Voltage Limit Settings" section for details). This button is available on most panels. 
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10.5 The Main Panel Window  
For more complete control of the piezo driver output the main window should be used. From this window all voltages can 
be adjusted as described above, however the function generator mode and master scan mode (not available when 
operating the MDT694A) will now be available. To open the main window click View > Main Panel in the top menu. To 
revert back to the compact view, simply click View > Compact Panel in the top menu. The main window can be seen in 
Figure 9. 

 

Figure 9 – Main View Window 

10.5.1 Display Mode Switch 

The displays are capable of operating in two modes while using the full screen window. The default mode (shown in figure 
9) will display the DC output voltage. The voltage controls below will change the voltage and maintain the setting until the 
next adjustment. 

Toggling the "Mode" switch, located next to each display, will change the display to the graph mode. The display will 
change from a numerical to graphical format. In order to adjust the graphical settings, open the "Function Generator" 
window by clicking View > Function Generator located in the top menu. 

10.6 The Master Scan Window 
The master scan option operates exactly the same as the MDT693A master scan mode. The voltage control adjusts the 
output voltage of all channels simultaneously with the same voltage. To enable this option click View > Master Scan in 
the top menu. Note that this option is only available with the multi-channel MDT693A. The window shown in Figure 10 will 
appear. Toggle the "Master Scan" switch to enable this feature. 

 

Figure 10 – Master Scan Window 

10.6.1 Master Controls 

Offset Voltage - An offset voltage can be added to all channels by adjusting this control. Simply adjust the knob, 
located to the left of the "Master Control" section. The offset voltage range can be adjusted in the system settings 
window (see Voltage Limit Settings" section for details). 

Amplitude Control -The amplitude control adjusts the peak-to-peak voltage level of an input function. Simply adjust 
the knob to change the amplitude from 0V to the voltage limit. Note that this voltage is added to the offset voltage. If 
the signal plus the offset exceed the voltage limit (typically 150V) the signal will be clipped at the limit. 
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Function Bar - This slide bar allows the user to select a function, such as Sine, Triangle, Ramp, or Pulse wave forms, 
to be output to the piezo device. 

Trigger Button - The trigger button clears the graph window and resets all functions to start from their 0 position. 

Legend Button - This button will display the graph legend on the graph, providing the user an easy way to distinguish 
between displayed channels. 

Rate Control - The rate control adjusts the speed of the sampling rate. This is based on an internal timer and may 
vary from computer to computer. These numbers are not based on a fixed sample time, such as ms. 

Resolution Control – The resolution adjusts the number of samples per waveform. The max number is 180 samples 
per waveform (2p). The resolution bar displays the factor that 180 is divided by. 

Example Resolution is equal to 4. The number of samples per function period equals 180/4 or 45. 

10.6.2 Local Controls 

Trim Gain - The Scan Trim Gain allows the user to compensate for differences in displacement (i.e. volt to 
displacement slope) between piezo elements by scaling the master control signal per channel. To adjust the gain 
simply adjust the slide bar or enter the correct gain into the box. Any voltage or graph signals will be amplified or 
scaled by this value. 

Offset Control - The offset controls for each channel allow the user to set an offset voltage independent of the other 
channels. This offset is added to the master offset and the function. 

10.7 The Function Generator Window 
The function generator window operates with the main panel. It allows the user to apply simple modulation functions to the 
output. To operate with higher frequency or waveforms it is recommended that the EXT input BNC’s are used. To access 
this window click View > Function Generator. The functions will not be applied to the output until the correct display 
mode is selected in the main window. 

 

Figure 11 – Function Generator Window 

Gain Control - The gain control adjusts the peak-to-peak voltage level of the function. Simply adjust the slide bar or input 
the voltage in the text box to change the amplitude from 0V to the voltage limit. Note that this voltage is added to the 
channel offset voltage. If the signal plus the offset exceed the voltage limit (typically 150V) the signal will be clipped at the 
limit. The voltage limits can be adjusted in the system setup window. 

Offset Control - The offset controls for each channel allow the user to set an offset voltage independent of the other 
channels. This offset is added to function and is limited by the voltage limit settings. 

Phase Control - The phase control bars allow the user to change the phase between channels. To adjust simply move 
the slide bar or add the appropriate phase correction to the text box. 

Trigger Button - The trigger button clears the graph window and resets all functions to start from their 0 position. 

Legend Button - This button will display the graph legend on the graph, providing the user an easy way to distinguish 
between displayed channels. 



_________________________________________________________________________________________________ 

  
Doc 12534-D02 Rev F 2/8/2012 

Page 27 of 29 

Function Bar - This slide bar allows the user to select a function, such as Sine, Triangle, Ramp, or Pulse waveforms, to 
be output to the piezo device. 

Rate Control - The rate control adjusts the speed of the sampling rate. This is based on an internal timer and may vary 
from computer to computer. These numbers are not based on a fixed sample time, such as ms. 

Resolution Control -The resolution adjusts the number of samples per waveform. The max number is 180 samples per 

waveform (2). The resolution bar displays the factor that 180 is divided by. Example: Resolution is equal to 4. The 
number of samples per function period equals 180/4 or 45. 

10.8 Serial Port Error Messages 

10.8.1 "System Setting Error" 

These messages may appear while operating in the System Parameters window (Tools > System Setup). They indicate 
that an out of range voltage was selected for a limit setting. The full range is 0V to 150V. Any voltages less than 0V, or 
greater than 150V, will cause these errors to occur. Check the limit values and correct where necessary. 

10.8.2 "MDT695 File Error" 

This error message indicates that one of the system .ini files was not found or that the system could not save settings to 
an .ini file. An .ini file may not be found if it was deleted, moved or corrupted. The program will create a new file and will 
use the default settings. Remember that your settings should be updated before using the driver. Example: the default 
voltage limits may be reset. If the device connected requires voltages to be less than the default, there will be no piezo 
protection. Note that some operating systems may not allow the user to save or update system settings files without 
administrator rights (Windows NT/2000). If this message occurs ("MDT695 File Error", "I/O File error, could not save new 
system settings, using defaults...") contact your system administrator. 

10.8.3 "Communication Error" 

Communication errors occur when the software cannot communicate with the MDT695.To correct this problem verify that 
the device is host driver (MDT693 or MDT694) is plugged in and the power is on. Verify that the serial cable is securely 
connected to the computer COM port. The cable provided with the MDT695 must be used. A standard serial cable will not 
work. If a replacement is required, contact Thorlabs. Also note that this error will also occur if the baud rate and com ports 
are manually set to the wrong values. Either correct the settings or select auto-detect so that the software detects the 
correct settings. 

10.8.4 "RS232 Communication" 

This is a Windows generated error, which may occur if the COM ports are being used by another device. To correct this, 
verify the communication settings and hardware connections. If everything appears OK, reboot the computer. 

Section 11: Maintenance and Troubleshooting 

11.1 Cleaning 
The MDT693A/MDT694A should only be cleaned with a soft cloth and mild soap detergent or isopropyl alcohol. Do not 
use a solvent-based cleaner. Do not use any cleaners on the LED display windows since the finish may be marred. 

11.2 Maintenance and Troubleshooting 
The MDT693A and MDT694A have no user serviceable parts. Do not open the unit. High voltages exist inside. If 
problems occur contact a Thorlabs representative to arrange for a repair, for replacement, or for general operation 
questions. 
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Appendix A: Bandwidth Performance 
The MDT693A is a precision, low-noise, low-drift voltage amplifier designed specifically to drive piezo actuators. There are 
two limitations on the system that need to be considered. Since piezo crystals can be modeled essentially as capacitors, it 
is easy to predict their dynamic performance using a basic set of equations as described below. 

A.1 Low Pass Filter 
Since the piezo can be modeled most accurately as a capacitor, the piezo will create a low pass filter with the output 
impedance of the driver. For both the MDT693A and MDT694A, the output impedance is specified as 150, 0.047µF. 

BW = 1/ (2*π*ROUT*C) 
Where: C = COUT + CPIEZO 

For example, we are connecting a piezo with a 1.6F capacitance to our MDT693A. Using the output impedances given in 
the spec section: 

BW = 1 / (2 * π * 150 * (0.047F + 1.6F)) 
BW = 644Hz 

A.2 Output Current Limit 
The output current limit also needs to be considered when determining system performance. Since the piezo is electrically 
equivalent to a capacitor (CPIEZO), the charge rate (∂V/∂t) needs to be considered. The max current for the MDT693A and 
MDT694A is 60mA (IOUT) 

IOUT = CPIEZO * ∂V/∂t 

The output current requirements are a factor of how quickly the piezo needs to be charged, not the voltage applied to it. 
Below are some common waveforms and their calculations. 

A.2.1 Linear Ramp Signal 

IOUT = C * V/t 
t = (C * V) / IOUT 

Where C = COUT + CPIEZO 

A.2.2 Triangle Wave 

IOUT = 2 * C * V/t 
f = IOUT / (2 * C * V) 

Where C = COUT + CPIEZO 

A.2.3 Sinusoid Wave 

Where V = VAMP * SIN (ωt) 
And C = COUT + CPIEZO  

And ω = 2πf 

IOUT = C * ω * VAMP * COS (ωt) 
IOUT (peak) = 2πf * VAMP * C 
f = IOUT / (2 * π * VAMP * C) 
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Section 12: Contacts 

USA, Canada, and South America 
Thorlabs, Inc. 
435 Route 206 
Newton, NJ 07860 
USA 
Tel: 973-579-7227 
Fax: 973-300-3600 
www.thorlabs.com 
email: feedback@thorlabs.com 

Europe 
Thorlabs GmbH 
Gaustr. 11 
85757 Karlsfeld 
Germany 
Tel: +49-(0)8131-5956-0 
Fax: +49-(0)8131-5956-99 
www.thorlabs.com 
email: Europe@thorlabs.com

Japan and Asia 
Thorlabs Japan Inc. 
5-17-1, Ohtsuka 
Bunkyo-ku Tokyo 112-0012 
Japan 
Tel: 81-3-5977-8401 
Fax: 81-3-5977-8402 
www.thorlabs.jp 
email: sales@thorlabs.jp 


